[apops] Cisco Security Advisory: Cisco IOS Software H.323 Denial of Serv

  • To: apops at apops dot net
  • Subject: [apops] Cisco Security Advisory: Cisco IOS Software H.323 Denial of Service Vulnerabilities
  • From: Cisco Systems Product Security Incident Response Team <psirt at cisco dot com>
  • Date: Wed, 22 Sep 2010 18:00:00 +0200
  • Cc: psirt at cisco dot com
  • Delivered-to: apops at mailman dot apnic dot net
  • List-archive: <http://mailman.apnic.net/mailing-lists/apops>
  • List-help: <mailto:apops-request@apops.net?subject=help>
  • List-id: Asia Pacific Operators Forum <apops.apops.net>
  • List-post: <mailto:apops@apops.net>
  • List-subscribe: <http://mailman.apnic.net/mailman/listinfo/apops>, <mailto:apops-request@apops.net?subject=subscribe>
  • List-unsubscribe: <http://mailman.apnic.net/mailman/listinfo/apops>, <mailto:apops-request@apops.net?subject=unsubscribe>
  • Prevent-nondelivery-report:
  • Reply-to: psirt@cisco.com
  • Sender: nobody@cisco.com
    • Hash: SHA1
      
      Cisco Security Advisory: Cisco IOS Software H.323 Denial of Service
      Vulnerabilities
      
      Advisory ID: cisco-sa-20100922-h323
      
      http://www.cisco.com/warp/public/707/cisco-sa-20100922-h323.shtml
      
      Revision 1.0
      
      For Public Release 2010 September 22 1600 UTC (GMT)
      
      - ---------------------------------------------------------------------
      
      Summary
      =======
      
      The H.323 implementation in Cisco IOS Software contains two
      vulnerabilities that may be exploited remotely to cause a denial of
      service (DoS) condition on a device that is running a vulnerable
      version of Cisco IOS Software.
      
      Cisco has released free software updates that address these
      vulnerabilities. There are no workarounds to mitigate these
      vulnerabilities other than disabling H.323 on the vulnerable device.
      
      This advisory is posted at 
      http://www.cisco.com/warp/public/707/cisco-sa-20100922-h323.shtml
      
      Note:  The September 22, 2010, Cisco IOS Software Security Advisory
      bundled publication includes six Cisco Security Advisories. Five of
      the advisories address vulnerabilities in Cisco IOS Software, and one
      advisory addresses vulnerabilities in Cisco Unified Communications
      Manager. Each advisory lists the releases that correct the
      vulnerability or vulnerabilities detailed in the advisory. The table
      at the following URL lists releases that correct all Cisco IOS
      Software vulnerabilities that have been published on September 22,
      2010, or earlier:
      
      http://www.cisco.com/warp/public/707/cisco-sa-20100922-bundle.shtml
      
      Individual publication links are in "Cisco Event Response: Semiannual
      Cisco IOS Software Security Advisory Bundled Publication" at the
      following link:
      
      http://www.cisco.com/web/about/security/intelligence/Cisco_ERP_sep10.html
      
      Affected Products
      =================
      
      These vulnerabilities only affect devices that are running Cisco IOS
      Software with H.323 voice services enabled.
      
      Vulnerable Products
      +------------------
      
      Cisco devices that are running affected Cisco IOS Software versions
      that are configured to process H.323 messages are affected by these
      vulnerabilities. H.323 is not enabled by default.
      
      To determine if the Cisco IOS Software device is running H.323
      services, issue the show process cpu | include H323 command, as shown
      in this example:
      
          Router# show process cpu | include H323
           249       16000           3       5333  0.00%  0.00%  0.00%   0 CCH323_CT
           250           0           1          0  0.00%  0.00%  0.00%   0 CCH323_DNS
          Router#
      
      In the previous example the processes CCH323_CT and CCH323_DNS are
      running on the device; therefore, the device is listening to H.323
      messages. The device is vulnerable if any of these processes (or
      similar) are active.
      
      Note: Creating a dial peer by issuing the dial-peer voice command
      will start the H.323 processes, which causes the Cisco IOS device to
      process H.323 messages.
      
      To determine the Cisco IOS Software release that is running on a
      Cisco product, administrators can log in to the device and issue the
      show version command to display the system banner. The system banner
      confirms that the device is running Cisco IOS Software by displaying
      text similar to "Cisco Internetwork Operating System Software" or
      "Cisco IOS Software." The image name displays in parentheses,
      followed by "Version" and the Cisco IOS Software release name. Other
      Cisco devices do not have the show version command or may provide
      different output.
      
      The following example identifies a Cisco product that is running
      Cisco IOS Software Release 12.3(26) with an installed image name of
      C2500-IS-L:
      
          Router# show version
          Cisco Internetwork Operating System Software
          IOS (tm) 2500 Software (C2500-IS-L), Version 12.3(26), RELEASE SOFTWARE (fc2)
          Technical Support: http://www.cisco.com/techsupport
          Copyright (c) 1986-2008 by cisco Systems, Inc.
          Compiled Mon 17-Mar-08 14:39 by dchih
      
      
          !--- output truncated
      
      
      The following example identifies a Cisco product that is running
      Cisco IOS Software Release 12.4(20)T with an installed image name of
      C1841-ADVENTERPRISEK9-M:
      
          Router# show version
          Cisco IOS Software, 1841 Software (C1841-ADVENTERPRISEK9-M), Version 12.4(20)T,
              RELEASE SOFTWARE (fc3)
          Technical Support: http://www.cisco.com/techsupport
          Copyright (c) 1986-2008 by Cisco Systems, Inc.
          Compiled Thu 10-Jul-08 20:25 by prod_rel_team
      
      
          !--- output truncated
      
      
      Additional information about Cisco IOS Software release naming
      conventions is available in "White Paper: Cisco IOS Reference Guide"
      at the following link: 
      http://www.cisco.com/web/about/security/intelligence/ios-ref.html
      
      Products Confirmed Not Vulnerable
      +--------------------------------
      
      Cisco IOS XR Software is not affected by these vulnerabilities.
      
      No other Cisco products are currently known to be affected by these
      vulnerabilities.
      
      Details
      =======
      
      H.323 is the International Telecommunication Union (ITU) standard for
      real-time multimedia communications and conferencing over
      packet-based (IP) networks. A subset of the H.323 standard is
      H.225.0, a standard that is used for call signaling protocols and
      media stream packetization over IP networks.
      
      The H.323 implementation in Cisco IOS Software contains two DoS
      vulnerabilities. An attacker can exploit these vulnerabilities
      remotely by sending crafted H.323 packets to an affected device that
      is running Cisco IOS Software. A TCP three-way handshake is required
      to exploit these vulnerabilities.
      
      These vulnerabilities are documented in Cisco Bug IDs CSCtc73759 (
      registered customers only) and CSCtd33567 ( registered customers
      only) , and have been assigned Common Vulnerabilities and Exposures
      (CVE) IDs CVE-2010-2828 and CVE-2010-2829, respectively.
      
      Vulnerability Scoring Details
      =============================
      
      Cisco has provided scores for the vulnerabilities in this advisory
      based on the Common Vulnerability Scoring System (CVSS). The CVSS
      scoring in this Security Advisory is done in accordance with CVSS
      version 2.0.
      
      CVSS is a standards-based scoring method that conveys vulnerability
      severity and helps determine urgency and priority of response.
      
      Cisco has provided a base and temporal score. Customers can then
      compute environmental scores to assist in determining the impact of
      the vulnerability in individual networks.
      
      Cisco has provided an FAQ to answer additional questions regarding
      CVSS at
      
      http://www.cisco.com/web/about/security/intelligence/cvss-qandas.html
      
      Cisco has also provided a CVSS calculator to help compute the
      environmental impact for individual networks at
      
      http://intellishield.cisco.com/security/alertmanager/cvss
      
      CSCtc73759 - Device crashing upon receipt of specific traffic
      
      CVSS Base Score - 7.8
      Access Vector           Network
      Access Complexity       Low
      Authentication          None
      Confidentiality Impact  None
      Integrity Impact        None
      Availability Impact     Complete
      
      CVSS Temporal Score - 6.4
      Exploitability          Functional
      Remediation Level       Official Fix
      Report Confidence       Confirmed
      
      CSCtd33567 - Traceback seen when receiving crafted H.323 packets
      
      CVSS Base Score - 7.8
      Access Vector           Network
      Access Complexity       Low
      Authentication          None
      Confidentiality Impact  None
      Integrity Impact        None
      Availability Impact     Complete
      
      CVSS Temporal Score - 6.4
      Exploitability          Functional
      Remediation Level       Official Fix
      Report Confidence       Confirmed
      
      Impact
      ======
      
      Successful exploitation of the vulnerabilities described in this
      advisory may cause the affected device to reload. Theses
      vulnerabilities could be exploited repeatedly to cause an extended
      DoS condition.
      
      Software Versions and Fixes
      ===========================
      
      When considering software upgrades, also consult 
      http://www.cisco.com/go/psirt and any subsequent advisories to 
      determine exposure and a complete upgrade solution.
      
      In all cases, customers should exercise caution to be certain the
      devices to be upgraded contain sufficient memory and that current
      hardware and software configurations will continue to be supported
      properly by the new release. If the information is not clear, contact
      the Cisco Technical Assistance Center (TAC) or your contracted
      maintenance provider for assistance.
      
      Each row of the following Cisco IOS Software table corresponds to a
      Cisco IOS Software train. If a particular train is vulnerable, the
      earliest releases that contain the fix are listed in the First Fixed
      Release For This Advisory column. The First Fixed Release for All
      Advisories in the September 2010 Bundle Publication column lists the
      earliest possible releases that correct all the published
      vulnerabilities in the Cisco IOS Software Security Advisory bundled
      publication. Cisco recommends upgrading to the latest available
      release, where possible.
      
      +--------------------------------------------------------------------+
      |   Major    |             Availability of Repaired Releases         |
      |  Release   |                                                       |
      |------------+-------------------------------------------------------|
      |  Affected  |                           |  First Fixed Release for  |
      | 12.0-Based |  First Fixed Release for  |   All Advisories in the   |
      |  Releases  |       This Advisory       |   September 2010 Bundle   |
      |            |                           |        Publication        |
      |--------------------------------------------------------------------|
      | There are no affected 12.0-based releases                          |
      |--------------------------------------------------------------------|
      |  Affected  |                           |  First Fixed Release for  |
      | 12.1-Based |  First Fixed Release for  |   All Advisories in the   |
      |  Releases  |       This Advisory       |   September 2010 Bundle   |
      |            |                           |        Publication        |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; first fixed   |
      |            |                           | in 12.4T                  |
      | 12.1       | Not Vulnerable            |                           |
      |            |                           | Releases up to and        |
      |            |                           | including 12.1(4b) are    |
      |            |                           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      | 12.1AA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1AX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1AY     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1AZ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1CX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1DA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1DB     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1DC     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1E      | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EB     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EC     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EO     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EU     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EV     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EW     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EY     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1EZ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1GA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1GB     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      | 12.1T      |                           |                           |
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.1(3a)T8 are  | including 12.1(3a)T8 are  |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      | 12.1XA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XB     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XC     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XD     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XE     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XF     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XG     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XH     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XI     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XJ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XL     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XM     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XP     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XQ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XR     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      | 12.1XS     |                           |                           |
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.1(3)XS are   | including 12.1(3)XS are   |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      | 12.1XT     |                           |                           |
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.1(2)XT2 are  | including 12.1(2)XT2 are  |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      | 12.1XU     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XV     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1XW     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1XX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      | 12.1XY     |                           |                           |
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.1(4)XY are   | including 12.1(4)XY are   |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      | 12.1XZ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.1YA     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1YB     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1YC     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1YD     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.1(5) | Releases prior to 12.1(5) |
      |            | YE6 are vulnerable,       | YE6 are vulnerable,       |
      | 12.1YE     | release 12.1(5)YE6 and    | release 12.1(5)YE6 and    |
      |            | later are not vulnerable; | later are not vulnerable; |
      |            | first fixed in 12.4       | first fixed in 12.4T      |
      |------------+---------------------------+---------------------------|
      | 12.1YF     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.1YH     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.1YI     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.1YJ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |  Affected  |                           |  First Fixed Release for  |
      | 12.2-Based |  First Fixed Release for  |   All Advisories in the   |
      |  Releases  |       This Advisory       |   September 2010 Bundle   |
      |            |                           |        Publication        |
      |------------+---------------------------+---------------------------|
      | 12.2       | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      | 12.2B      |                           |                           |
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.2(2)B7 are   | including 12.2(2)B7 are   |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      | 12.2BC     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2BW     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.2SB                 | in 12.2SB                 |
      | 12.2BX     |                           |                           |
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.2(15)BX are  | including 12.2(15)BX are  |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      | 12.2BY     |                           |                           |
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.2(2)BY3 are  | including 12.2(2)BY3 are  |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      | 12.2BZ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2CX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2CY     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2CZ     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2DA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2DD     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2DX     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2EW     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2EWA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2EX     | Vulnerable; migrate to    | Not Vulnerable            |
      |            | any release in 12.2SE     |                           |
      |------------+---------------------------+---------------------------|
      | 12.2EY     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2EZ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2FX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2FY     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2FZ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IRA    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IRB    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IRC    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IRD    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IRE    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXA    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXB    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXC    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXD    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXE    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXF    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXG    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2IXH    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2JA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2JK     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2MB     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.2(15)MC1 are | including 12.2(15)MC1 are |
      |            | not vulnerable.           | not vulnerable. Releases  |
      | 12.2MC     |                           | 12.2(15)MC2b and later    |
      |            | Releases 12.2(15)MC2b and | are not vulnerable; first |
      |            | later are not vulnerable; | fixed in 12.4T            |
      |            | first fixed in 12.4       |                           |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2MRA    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2MRB    | Not Vulnerable            | 12.2(33)MRB2              |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Releases prior to 12.2    |
      | 12.2S      | (30)S are vulnerable,     | (30)S are vulnerable,     |
      |            | release 12.2(30)S and     | release 12.2(30)S and     |
      |            | later are not vulnerable  | later are not vulnerable  |
      |------------+---------------------------+---------------------------|
      |            | 12.2(31)SB19              | 12.2(31)SB19              |
      |            |                           |                           |
      | 12.2SB     | Releases prior to 12.2    | Releases prior to 12.2    |
      |            | (33)SB5 are vulnerable,   | (33)SB5 are vulnerable,   |
      |            | release 12.2(33)SB5 and   | release 12.2(33)SB5 and   |
      |            | later are not vulnerable  | later are not vulnerable  |
      |------------+---------------------------+---------------------------|
      | 12.2SBC    | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.2SB                 | in 12.2SB                 |
      |------------+---------------------------+---------------------------|
      | 12.2SCA    | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.2SCB                | in 12.2SCB                |
      |------------+---------------------------+---------------------------|
      |            | 12.2(33)SCB10             |                           |
      |            |                           |                           |
      | 12.2SCB    | 12.2(33)SCB9              | 12.2(33)SCB9              |
      |            |                           |                           |
      |            | 12.2(33)SCB8              |                           |
      |------------+---------------------------+---------------------------|
      |            | 12.2(33)SCC5              |                           |
      | 12.2SCC    |                           | 12.2(33)SCC5              |
      |            | 12.2(33)SCC4              |                           |
      |------------+---------------------------+---------------------------|
      |            | 12.2(33)SCD3              |                           |
      | 12.2SCD    |                           | 12.2(33)SCD3              |
      |            | 12.2(33)SCD4              |                           |
      |------------+---------------------------+---------------------------|
      | 12.2SE     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SEA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SEB    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SEC    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SED    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SEE    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SEF    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SEG    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Releases prior to 12.2    |
      |            | (40)SG are vulnerable,    | (40)SG are vulnerable,    |
      | 12.2SG     | release 12.2(40)SG and    | release 12.2(40)SG and    |
      |            | later are not vulnerable; | later are not vulnerable; |
      |            | migrate to any release in | migrate to any release in |
      |            | 12.2SGA                   | 12.2SGA                   |
      |------------+---------------------------+---------------------------|
      | 12.2SGA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SL     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SM     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SO     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SQ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Releases prior to 12.2    |
      | 12.2SRA    | (33)SRA6 are vulnerable,  | (33)SRA6 are vulnerable,  |
      |            | release 12.2(33)SRA6 and  | release 12.2(33)SRA6 and  |
      |            | later are not vulnerable  | later are not vulnerable  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Releases prior to 12.2    |
      | 12.2SRB    | (33)SRB1 are vulnerable,  | (33)SRB1 are vulnerable,  |
      |            | release 12.2(33)SRB1 and  | release 12.2(33)SRB1 and  |
      |            | later are not vulnerable  | later are not vulnerable  |
      |------------+---------------------------+---------------------------|
      | 12.2SRC    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SRD    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SRE    | Not Vulnerable            | 12.2(33)SRE1              |
      |------------+---------------------------+---------------------------|
      | 12.2STE    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SU     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Releases prior to 12.2    |
      |            | (29b)SV1 are vulnerable,  | (29b)SV1 are vulnerable,  |
      | 12.2SV     | release 12.2(29b)SV1 and  | release 12.2(29b)SV1 and  |
      |            | later are not vulnerable; | later are not vulnerable; |
      |            | migrate to any release in | migrate to any release in |
      |            | 12.2SVD                   | 12.2SVD                   |
      |------------+---------------------------+---------------------------|
      | 12.2SVA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SVC    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SVD    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SVE    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.2(21)SW1 are | including 12.2(21)SW1 are |
      |            | not vulnerable.           | not vulnerable. Releases  |
      | 12.2SW     |                           | 12.2(25)SW12 and later    |
      |            | Releases 12.2(25)SW12 and | are not vulnerable; first |
      |            | later are not vulnerable; | fixed in 12.4T            |
      |            | first fixed in 12.4T      |                           |
      |------------+---------------------------+---------------------------|
      |            |                           | Releases up to and        |
      | 12.2SX     | Not Vulnerable            | including 12.2(14)SX2 are |
      |            |                           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Vulnerable; Contact your  |
      |            | (17b)SXA2 are vulnerable, | support organization per  |
      | 12.2SXA    | release 12.2(17b)SXA2 and | the instructions in       |
      |            | later are not vulnerable  | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Vulnerable; Contact your  |
      |            | (17d)SXB7 are vulnerable, | support organization per  |
      | 12.2SXB    | release 12.2(17d)SXB7 and | the instructions in       |
      |            | later are not vulnerable; | Obtaining Fixed Software  |
      |            | migrate to any release in | section of this advisory  |
      |            | 12.2SXE                   |                           |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Vulnerable; Contact your  |
      |            | (18)SXD2 are vulnerable,  | support organization per  |
      | 12.2SXD    | release 12.2(18)SXD2 and  | the instructions in       |
      |            | later are not vulnerable  | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2SXE    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Only 12.2(18)SXF7 and     | Releases prior to 12.2    |
      | 12.2SXF    | 12.2(18)SXF8 are          | (18)SXF11 are vulnerable, |
      |            | vulnerable                | release 12.2(18)SXF11 and |
      |            |                           | later are not vulnerable  |
      |------------+---------------------------+---------------------------|
      | 12.2SXH    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2SXI    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  |                           |
      |            | support organization per  |                           |
      | 12.2SY     | the instructions in       | Not Vulnerable            |
      |            | Obtaining Fixed Software  |                           |
      |            | section of this advisory  |                           |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2SZ     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2T      | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2TPC    | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   |                           |
      |            | in 12.4                   |                           |
      | 12.2XA     |                           | Vulnerable; first fixed   |
      |            | Releases up to and        | in 12.4T                  |
      |            | including 12.2(1)XA are   |                           |
      |            | not vulnerable.           |                           |
      |------------+---------------------------+---------------------------|
      | 12.2XB     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XC     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XD     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XE     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2XF     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2XG     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XH     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XI     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XJ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XK     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XL     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XM     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    |                           |
      |            | (33)XN1 are vulnerable,   | Vulnerable; first fixed   |
      | 12.2XN     | release 12.2(33)XN1 and   | in 12.2SB                 |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.2SB     |                           |
      |------------+---------------------------+---------------------------|
      | 12.2XNA    | Please see Cisco IOS-XE   | Please see Cisco IOS-XE   |
      |            | Software Availability     | Software Availability     |
      |------------+---------------------------+---------------------------|
      | 12.2XNB    | Please see Cisco IOS-XE   | Please see Cisco IOS-XE   |
      |            | Software Availability     | Software Availability     |
      |------------+---------------------------+---------------------------|
      | 12.2XNC    | Please see Cisco IOS-XE   | Please see Cisco IOS-XE   |
      |            | Software Availability     | Software Availability     |
      |------------+---------------------------+---------------------------|
      | 12.2XND    | Please see Cisco IOS-XE   | Please see Cisco IOS-XE   |
      |            | Software Availability     | Software Availability     |
      |------------+---------------------------+---------------------------|
      | 12.2XNE    | Please see Cisco IOS-XE   | Please see Cisco IOS-XE   |
      |            | Software Availability     | Software Availability     |
      |------------+---------------------------+---------------------------|
      | 12.2XNF    | Please see Cisco IOS-XE   | Please see Cisco IOS-XE   |
      |            | Software Availability     | Software Availability     |
      |------------+---------------------------+---------------------------|
      | 12.2XO     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2XQ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XR     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2XS     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XT     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XU     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XV     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2XW     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2YA     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YB     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YC     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YD     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YE     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YF     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2YG     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YH     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YJ     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YK     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YL     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2YM     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YN     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  |                           |
      |            | support organization per  |                           |
      | 12.2YO     | the instructions in       | Not Vulnerable            |
      |            | Obtaining Fixed Software  |                           |
      |            | section of this advisory  |                           |
      |------------+---------------------------+---------------------------|
      | 12.2YP     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2YQ     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2YR     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2YS     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YT     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YU     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.2    | Releases prior to 12.2    |
      | 12.2YV     | (11)YV1 are vulnerable,   | (11)YV1 are vulnerable,   |
      |            | release 12.2(11)YV1 and   | release 12.2(11)YV1 and   |
      |            | later are not vulnerable  | later are not vulnerable  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YW     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YX     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YY     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2YZ     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2ZA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Releases up to and        | Releases up to and        |
      | 12.2ZB     | including 12.2(8)ZB are   | including 12.2(8)ZB are   |
      |            | not vulnerable.           | not vulnerable.           |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2ZC     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2ZD     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.2ZE     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2ZF     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.2ZG     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.2ZH     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2ZJ     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2ZL     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.2ZP     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; migrate to    | Vulnerable; Contact your  |
      |            | any release in 12.2SXH    | support organization per  |
      | 12.2ZU     |                           | the instructions in       |
      |            | Releases up to and        | Obtaining Fixed Software  |
      |            | including 12.2(18)ZU are  | section of this advisory  |
      |            | not vulnerable.           |                           |
      |------------+---------------------------+---------------------------|
      | 12.2ZX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2ZY     | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            |                           | support organization per  |
      | 12.2ZYA    | Not Vulnerable            | the instructions in       |
      |            |                           | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |  Affected  |                           |  First Fixed Release for  |
      | 12.3-Based |  First Fixed Release for  |   All Advisories in the   |
      |  Releases  |       This Advisory       |   September 2010 Bundle   |
      |            |                           |        Publication        |
      |------------+---------------------------+---------------------------|
      | 12.3       | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3B      | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3BC     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3BW     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3EU     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3JA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3JEA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3JEB    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3JEC    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3JED    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |            | Releases up to and        | Releases up to and        |
      |            | including 12.3(2)JK3 are  | including 12.3(2)JK3 are  |
      |            | not vulnerable.           | not vulnerable. Releases  |
      | 12.3JK     |                           | 12.3(8)JK1 and later are  |
      |            | Releases 12.3(8)JK1 and   | not vulnerable; first     |
      |            | later are not vulnerable; | fixed in 12.4T            |
      |            | first fixed in 12.4       |                           |
      |------------+---------------------------+---------------------------|
      | 12.3JL     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3JX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.3T      | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            |                           | Vulnerable; Contact your  |
      |            | Releases up to and        | support organization per  |
      | 12.3TPC    | including 12.3(4)TPC11a   | the instructions in       |
      |            | are not vulnerable.       | Obtaining Fixed Software  |
      |            |                           | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.3VA     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.3(2) |                           |
      |            | XA7 are vulnerable,       | Vulnerable; first fixed   |
      | 12.3XA     | release 12.3(2)XA7 and    | in 12.4T                  |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.4       |                           |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.3XB     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.3XC     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XD     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XE     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.3XF     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.3XG     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.3(7) | Releases prior to 12.3(7) |
      |            | XI11 are vulnerable,      | XI11 are vulnerable,      |
      | 12.3XI     | release 12.3(7)XI11 and   | release 12.3(7)XI11 and   |
      |            | later are not vulnerable; | later are not vulnerable; |
      |            | first fixed in 12.2SB     | first fixed in 12.2SB     |
      |------------+---------------------------+---------------------------|
      | 12.3XJ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.3YX                 | in 12.4XR                 |
      |------------+---------------------------+---------------------------|
      | 12.3XK     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XL     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XQ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XR     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XS     | Not Vulnerable            | Vulnerable; first fixed   |
      |            |                           | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   |                           |
      |            | in 12.4T                  |                           |
      | 12.3XU     |                           | Vulnerable; first fixed   |
      |            | Releases up to and        | in 12.4T                  |
      |            | including 12.3(8)XU1 are  |                           |
      |            | not vulnerable.           |                           |
      |------------+---------------------------+---------------------------|
      | 12.3XW     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.3YX                 | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XX     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XY     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3XZ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4                   | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YA     | Not Vulnerable            | Vulnerable; first fixed   |
      |            |                           | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YD     | Not Vulnerable            | Vulnerable; first fixed   |
      |            |                           | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YF     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.3YX                 | in 12.4XR                 |
      |------------+---------------------------+---------------------------|
      | 12.3YG     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YH     | Not Vulnerable            | Vulnerable; first fixed   |
      |            |                           | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YI     | Not Vulnerable            | Vulnerable; first fixed   |
      |            |                           | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YJ     | Not Vulnerable            | Vulnerable; first fixed   |
      |            |                           | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.3    |                           |
      |            | (11)YK3 are vulnerable,   | Vulnerable; first fixed   |
      | 12.3YK     | release 12.3(11)YK3 and   | in 12.4T                  |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.4T      |                           |
      |------------+---------------------------+---------------------------|
      | 12.3YM     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YQ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; first fixed   |                           |
      |            | in 12.4T                  |                           |
      | 12.3YS     |                           | Vulnerable; first fixed   |
      |            | Releases up to and        | in 12.4T                  |
      |            | including 12.3(11)YS1 are |                           |
      |            | not vulnerable.           |                           |
      |------------+---------------------------+---------------------------|
      | 12.3YT     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YU     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.3YX     | 12.3(14)YX17              | Vulnerable; first fixed   |
      |            |                           | in 12.4XR                 |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.3YZ     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.3ZA     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |  Affected  |                           |  First Fixed Release for  |
      | 12.4-Based |  First Fixed Release for  |   All Advisories in the   |
      |  Releases  |       This Advisory       |   September 2010 Bundle   |
      |            |                           |        Publication        |
      |------------+---------------------------+---------------------------|
      | 12.4       | 12.4(25d)                 | 12.4(25d)                 |
      |------------+---------------------------+---------------------------|
      | 12.4GC     | 12.4(24)GC2               | 12.4(24)GC2               |
      |------------+---------------------------+---------------------------|
      | 12.4JA     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JDA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JDC    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JDD    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JHA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JHB    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JK     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JL     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JMA    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JMB    | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JX     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4JY     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      | 12.4MD     | Not Vulnerable            | 12.4(24)MD2               |
      |------------+---------------------------+---------------------------|
      | 12.4MDA    | 12.4(22)MDA4              | 12.4(22)MDA4              |
      |------------+---------------------------+---------------------------|
      | 12.4MR     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4MRA                | in 12.4MRA                |
      |------------+---------------------------+---------------------------|
      | 12.4MRA    | 12.4(20)MRA1              | 12.4(20)MRA1              |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.4    |                           |
      |            | (15)SW6 are vulnerable,   | Vulnerable; first fixed   |
      | 12.4SW     | release 12.4(15)SW6 and   | in 12.4T                  |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.4T      |                           |
      |------------+---------------------------+---------------------------|
      |            | 12.4(15)T14               | 12.4(15)T14               |
      |            |                           |                           |
      | 12.4T      | 12.4(20)T6                | 12.4(20)T6                |
      |            |                           |                           |
      |            | 12.4(24)T4                | 12.4(24)T4                |
      |------------+---------------------------+---------------------------|
      | 12.4XA     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.4XB     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.4XC     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.4XD     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.4(6) | Releases prior to 12.4(6) |
      |            | XE5 are vulnerable,       | XE5 are vulnerable,       |
      | 12.4XE     | release 12.4(6)XE5 and    | release 12.4(6)XE5 and    |
      |            | later are not vulnerable; | later are not vulnerable; |
      |            | first fixed in 12.4T      | first fixed in 12.4T      |
      |------------+---------------------------+---------------------------|
      | 12.4XF     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.4(9) |                           |
      |            | XG5 are vulnerable,       | Vulnerable; first fixed   |
      | 12.4XG     | release 12.4(9)XG5 and    | in 12.4T                  |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.4T      |                           |
      |------------+---------------------------+---------------------------|
      | 12.4XJ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.4XK     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.4XL     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.4    |                           |
      |            | (15)XM3 are vulnerable,   | Vulnerable; first fixed   |
      | 12.4XM     | release 12.4(15)XM3 and   | in 12.4T                  |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.4T      |                           |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.4XN     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.4XP     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Releases up to and        |                           |
      |            | including 12.4(15)XQ are  |                           |
      |            | not vulnerable.           | 12.4(15)XQ6; Available on |
      | 12.4XQ     |                           | 22-SEP-10                 |
      |            | Releases 12.4(15)XQ6 and  |                           |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.4T      |                           |
      |------------+---------------------------+---------------------------|
      |            |                           | 12.4(15)XR9               |
      | 12.4XR     | Not Vulnerable            |                           |
      |            |                           | 12.4(22)XR7               |
      |------------+---------------------------+---------------------------|
      | 12.4XT     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.4XV     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      | 12.4XW     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.4XY     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.4XZ     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      | 12.4YA     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 12.4T                  | in 12.4T                  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.4YB     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Vulnerable; Contact your  | Vulnerable; Contact your  |
      |            | support organization per  | support organization per  |
      | 12.4YD     | the instructions in       | the instructions in       |
      |            | Obtaining Fixed Software  | Obtaining Fixed Software  |
      |            | section of this advisory  | section of this advisory  |
      |------------+---------------------------+---------------------------|
      |            | Releases prior to 12.4    |                           |
      |            | (24)YE1 are vulnerable,   |                           |
      | 12.4YE     | release 12.4(24)YE1 and   | 12.4(24)YE1               |
      |            | later are not vulnerable; |                           |
      |            | first fixed in 12.4T      |                           |
      |------------+---------------------------+---------------------------|
      | 12.4YG     | 12.4(24)YG3               | 12.4(24)YG3               |
      |------------+---------------------------+---------------------------|
      |  Affected  |                           |  First Fixed Release for  |
      | 15.0-Based |  First Fixed Release for  |   All Advisories in the   |
      |  Releases  |       This Advisory       |   September 2010 Bundle   |
      |            |                           |        Publication        |
      |------------+---------------------------+---------------------------|
      | 15.0M      | 15.0(1)M3                 | 15.0(1)M3                 |
      |------------+---------------------------+---------------------------|
      |            | Cisco 7600 and 10000      | Cisco 7600 and 10000      |
      |            | Series routers: Not       | Series routers: 15.0(1)S1 |
      |            | Vulnerable                | (available early October  |
      |            |                           | 2010)                     |
      | 15.0S      | Cisco ASR 1000 Series     |                           |
      |            | routes: Please see Cisco  | Cisco ASR 1000 Series     |
      |            | IOS-XE Software           | routes: Please see Cisco  |
      |            | Availability              | IOS-XE Software           |
      |            |                           | Availability              |
      |------------+---------------------------+---------------------------|
      | 15.0XA     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 15.1T                  | in 15.1T                  |
      |------------+---------------------------+---------------------------|
      | 15.0XO     | Not Vulnerable            | Not Vulnerable            |
      |------------+---------------------------+---------------------------|
      |  Affected  |                           |  First Fixed Release for  |
      | 15.1-Based |  First Fixed Release for  |   All Advisories in the   |
      |  Releases  |       This Advisory       |   September 2010 Bundle   |
      |            |                           |        Publication        |
      |------------+---------------------------+---------------------------|
      |            | 15.1(1)T1                 |                           |
      | 15.1T      |                           | 15.1(2)T1                 |
      |            | 15.1(2)T0a                |                           |
      |------------+---------------------------+---------------------------|
      | 15.1XB     | Vulnerable; first fixed   | Vulnerable; first fixed   |
      |            | in 15.1T                  | in 15.1T                  |
      +--------------------------------------------------------------------+
      
      Cisco IOS XE Software
      +--------------------
      
      +-------------------------------------------------------------------+
      | Cisco IOS |   First Fixed    |    First Fixed Release for All     |
      |    XE     | Release for This |  Advisories in the September 2010  |
      |  Release  |     Advisory     |         Bundle Publication         |
      |-----------+------------------+------------------------------------|
      | 2.1.x     | Not Vulnerable   | Not Vulnerable                     |
      |-----------+------------------+------------------------------------|
      | 2.2.x     | Not Vulnerable   | Not Vulnerable                     |
      |-----------+------------------+------------------------------------|
      | 2.3.x     | Not Vulnerable   | Not Vulnerable                     |
      |-----------+------------------+------------------------------------|
      | 2.4.x     | Not Vulnerable   | Not Vulnerable                     |
      |-----------+------------------+------------------------------------|
      | 2.5.x     | 2.5.2            | Vulnerable; migrate to 2.6.2 or    |
      |           |                  | later                              |
      |-----------+------------------+------------------------------------|
      | 2.6.x     | 2.6.1            | 2.6.2                              |
      |-----------+------------------+------------------------------------|
      | 3.1.xS    | Not Vulnerable   | Not Vulnerable                     |
      +-------------------------------------------------------------------+
      
      For mapping of Cisco IOS XE to Cisco IOS releases, please refer to
      the Cisco IOS XE 2 and Cisco IOS XE 3S Release Notes.
      
      Workarounds
      ===========
      
      There are no workarounds to mitigate these vulnerabilities apart from
      disabling H.323 if the Cisco IOS device does not require it. Applying
      access lists on interfaces that should not accept H.323 traffic and
      placing firewalls in strategic locations may greatly reduce exposure
      until an upgrade can be performed.
      
      Cisco provides Solution Reference Network Design (SRND) guides to
      help design and deploy networking solutions, which can be found at
      http://www.cisco.com/go/srnd Voice Security best practices are
      covered in the Cisco Unified Communications SRND Based on Cisco
      Unified Communications Manager 6.x at 
      http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/6x/security.html
      
      To disable all H.323 call processing, administrators can issue the
      call service stop forced command under the voice service voip mode,
      as shown in this example:
      
          voice service voip
           h323
            call service stop forced
      
      Note: The call service stop forced command disables all H.323 call
      processing.
      
      Additional mitigations that can be deployed on Cisco devices within
      the network are available in the companion document "Cisco Applied
      Mitigation Bulletin: Identifying and Mitigating Exploitation of the
      Multiple Vulnerabilities in Cisco Voice Products", which is available
      at the following location: 
      http://www.cisco.com/warp/public/707/cisco-amb-20100922-voice.shtml
      
      Obtaining Fixed Software
      ========================
      
      Cisco has released free software updates that address these
      vulnerabilities. Prior to deploying software, customers should
      consult their maintenance provider or check the software for feature
      set compatibility and known issues specific to their environment.
      
      Customers may only install and expect support for the feature sets
      they have purchased. By installing, downloading, accessing or
      otherwise using such software upgrades, customers agree to be bound
      by the terms of Cisco's software license terms found at 
      http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html
      or as otherwise set forth at Cisco.com Downloads at 
      http://www.cisco.com/public/sw-center/sw-usingswc.shtml
      
      Do not contact psirt at cisco dot com or security-alert at cisco dot com for
      software upgrades.
      
      Customers with Service Contracts
      +-------------------------------
      
      Customers with contracts should obtain upgraded software through
      their regular update channels. For most customers, this means that
      upgrades should be obtained through the Software Center on Cisco's
      worldwide website at http://www.cisco.com
      
      Customers using Third Party Support Organizations
      +------------------------------------------------
      
      Customers whose Cisco products are provided or maintained through
      prior or existing agreements with third-party support organizations,
      such as Cisco Partners, authorized resellers, or service providers
      should contact that support organization for guidance and assistance
      with the appropriate course of action in regards to this advisory.
      
      The effectiveness of any workaround or fix is dependent on specific
      customer situations, such as product mix, network topology, traffic
      behavior, and organizational mission. Due to the variety of affected
      products and releases, customers should consult with their service
      provider or support organization to ensure any applied workaround or
      fix is the most appropriate for use in the intended network before it
      is deployed.
      
      Customers without Service Contracts
      +----------------------------------
      
      Customers who purchase direct from Cisco but do not hold a Cisco
      service contract, and customers who purchase through third-party
      vendors but are unsuccessful in obtaining fixed software through
      their point of sale should acquire upgrades by contacting the Cisco
      Technical Assistance Center (TAC). TAC contacts are as follows.
      
        * +1 800 553 2447 (toll free from within North America)
        * +1 408 526 7209 (toll call from anywhere in the world)
        * e-mail: tac at cisco dot com
      
      Customers should have their product serial number available and be
      prepared to give the URL of this notice as evidence of entitlement to
      a free upgrade. Free upgrades for non-contract customers must be
      requested through the TAC.
      
      Refer to 
      http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html
      for additional TAC contact information, including localized telephone
      numbers, and instructions and e-mail addresses for use in various 
      languages.
      
      Exploitation and Public Announcements
      =====================================
      
      The Cisco PSIRT is not aware of any public announcements or malicious
      use of the vulnerabilities described in this advisory.
      
      These vulnerabilities were found during Cisco internal testing.
      
      Status of this Notice: FINAL
      ============================
      
      THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY
      KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF
      MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE
      INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS
      AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS
      DOCUMENT AT ANY TIME.
      
      A stand-alone copy or Paraphrase of the text of this document that
      omits the distribution URL in the following section is an
      uncontrolled copy, and may lack important information or contain
      factual errors.
      
      Distribution
      ============
      
      This advisory is posted on Cisco's worldwide website at :
      
      http://www.cisco.com/warp/public/707/cisco-sa-2010922-h323.shtml
      
      In addition to worldwide web posting, a text version of this notice
      is clear-signed with the Cisco PSIRT PGP key and is posted to the
      following e-mail and Usenet news recipients.
      
        * cust-security-announce at cisco dot com
        * first-bulletins at lists dot first dot org
        * bugtraq at securityfocus dot com
        * vulnwatch at vulnwatch dot org
        * cisco at spot dot colorado dot edu
        * cisco-nsp at puck dot nether dot net
        * full-disclosure at lists.grok dot org dot uk
        * comp.dcom.sys.cisco at newsgate dot cisco dot com
      
      Future updates of this advisory, if any, will be placed on Cisco's
      worldwide website, but may or may not be actively announced on
      mailing lists or newsgroups. Users concerned about this problem are
      encouraged to check the above URL for any updates.
      
      Revision History
      ================
      
      +-----------------------------------------+
      | Revision |                   | Initial  |
      | 1.0      | 2010-September-22 | public   |
      |          |                   | release. |
      +-----------------------------------------+
      
      Cisco Security Procedures
      =========================
      
      Complete information on reporting security vulnerabilities in Cisco
      products, obtaining assistance with security incidents, and
      registering to receive security information from Cisco, is available
      on Cisco's worldwide website at 
      http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html
      This includes instructions for press inquiries regarding Cisco 
      security notices. All Cisco security advisories are available at 
      http://www.cisco.com/go/psirt
      -----BEGIN PGP SIGNATURE-----
      Version: GnuPG v1.4.10 (Darwin)
      
      iEYEARECAAYFAkyZ/SoACgkQ86n/Gc8U/uCR8ACfbSQwX1PMeEwUVJWTSeGDtyrW
      jTMAnRuYshIzCis7CHMiORtLxeSKi80b
      =B67E
      -----END PGP SIGNATURE-----